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About SigSketch 
The DOR’s Windows-based CAMA application contains a sketch program called SigSketch. Instead of typing in a 
set of instructions (a vector) to construct a sketch, you use drawing tools and the mouse to create a replica of the 
building’s perimeter on screen.  The sketch program then creates the vector and transfers the information back to the 
new Oracle RPIS database. If you are familiar with image editing programs, you will already be familiar with many 
of the tools and menu options found in SigSketch. 
 
 

The menu bar 

The drawing box - 
the sketch appears in 
this area as you draw 

The tool bar 

The status line 
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Accessing SigSketch 
 
The sketch program can be accessed from one of two records: 
 
 Residence record – for sketching residential properties 
 Commercial Section record – for sketching commercial sections. 

 
In either record, click the Sketch icon on the main menu bar to enter the SigSketch module. The 
Residence record is shown below as an example. 
 
 
 

 

click the Sketch 
icon to access 
SigSketch 

 
 
The SigSketch screen is divided into four sections: 
 
 the menu bar 
 the drawing box 
 the tool bar 
 the status line 

 
Each of these screen sections will be explained in detail in this user guide. Most examples will 
show residential sketching; the commercial sketch module works the same way but only the 
perimeter of each section is sketched. Information on commercial sketching is included at the 
end of this user guide. 
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The Menu Bar 
The menu bar groups similar options together under a descriptive menu heading. Many of the 
options available in the menus are also available as buttons on a toolbar. You can select the 
option either by clicking on the tool icon or by opening the appropriate menu and choosing the 
option. 
 

 
 
The menus and their available options are decribed below. 

the File menu 
Refresh – replaces the current sketch with the most recently saved copy stored in the database. 
Save – saves the current sketch to the database without exiting the sketch program. Frequent use 
of this option is recommended while drawing complex sketches. 
Print – prints a copy of the current sketch, including the parcel id and the section table. 
Exit – exits the sketch program and returns you to the Residence or Commercial Section record. 
If you have not saved any changes made to the sketch, the program will prompt you to save or 
discard changes before exiting. 

the Edit Vector option  
Clicking Edit Vector does not display a menu - it allows you to manually enter or edit a sketch 
vector. (Note: the vector language appears similar to the previous RPIS Version 1 style but is not 
exactly the same. Use of this option is not recommended for novices.)The tool bar and status bar 
are replaced with a Vector window containing the actual vector language. Use the Cut, Copy and 
Paste buttons to edit the vector language. The Redraw button will read the changes and redraw 
the sketch accordingly. The Calc Areas button will add a line at the end of the vector showing 
the section areas. If you select this option by accident, simply click the Exit button at the bottom 
right of the window. 

the Scale menu 
This menu’s options change the scale of the drawing area.  Selecting a new scale will change the 
appearance of your sketch and may also change its location on the screen. If you wish to keep the 
new scale but your sketch has moved partially off-screen, use the Pan Drawing button (the icon 
with the hand) to drag the sketch back to the middle of the screen.  You can return the drawing to 
normal scale by clicking the Autoscale Drawing button (the blue icon that says 1:1.) 

the Tools menu 
You can select drawing tools by using this menu or by clicking the drawing tool button on the 
tool bar (see the Tool bar section for more information.) If a drawing tool button has been 
selected, a checkmark will appear next to the menu option. 
Polyline – this drawing tool allows you to draw a sketch using separate lines. These lines can be 
straight or angled. This is useful for drawing buildings that are not a perfect square or rectangle. 
Box – this tool draws square or rectangular boxes of any size. You can use this tool to draw a 
building without having to draw each side separately. 
Arc – use this tool to draw curved lines. 
Reverse Arc – this tool also draws curved lines, but in the opposite direction from the Arc tool. 
Ellipse – this tool draws circles or ovals. 
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Options menu  
Various display options can be toggled (turned on or off) from this menu. All options are toggled 
on when checked. 
 
Dimensions-On - toggles display of the perimeter dimensions on/off.  
Label Code-On - toggles display of the section labels on/off. 
Area-On - toggles display of the section areas on/off. 
Grid-On - toggles display of the background grid on/off. When toggled on, the grid will appear in 
the background as evenly spaced gray dots. (The grid does not print even when visible on 
screen.) 
Snap line - this feature will “snap” a line to a 45º angle. If you wish to draw lines with any other 
angle, turn off the Snap Line feature. (It is easiest to draw perfectly straight lines with Snap Line 
enabled.) 
Level Color-On - with this option toggled on, section levels will appear in different colors when 
using the Draw Levels button.  
 

the Help menu  
Click Contents to access Sigma’s OnLine Help system. All currently available help topics appear 
in underlined green text. Topics with a solid underline have their own pages containing detailed 
information.  Topics with a dotted underline do not have their own help page but are described 
using pop-up windows containing a brief explanation. Click File > Exit to close the Help 
window (or click the X in the top right-hand corner of the window.) 
 
Clicking “About SigSketch” opens a small informational window with Sigma’s company 
information and the program’s version number and date. Click OK to close the window. 
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The Drawing Box 
 
The large blank area below the menu bar is called the Drawing Box. This is where you will draw 
your sketch.   
 
Each time you complete a section (a complete square, rectangle, circle or polygon) a Section 
Label box will appear. You must enter a Usage Code to tell the sketch program what type of area 
you have drawn. The codes are listed in a pull-down menu; the familiar codes are there, along 
with some you may not have seen before.   
 

   

Usage Codes (pull-
down menu) 

the scroll bar 
indicates that 
more choices 
are available by 
scrolling down 
the list  

 
 
 

Drawing a sketch 

Using the drawing tools 
Select a drawing tool (box, polyline, arc, reverse arc or ellipse) by clicking an icon on the toolbar 
or selecting a tool from the Tool menu.  
 

 
 
The most commonly used tool for drawing a standard rectangular house is the box tool .  
 
To draw a sketch using separate straight lines and/or 45° angles, use the polyline tool . (To 
draw angled lines using any other angle, turn off the Snap Line option (click Options on the 
menu bar and make sure Snap line is not checked.) 
 
Use the arc/reverse arc tools to draw curved lines . 
 
Use the ellipse tool to draw circles or ovals . 
 
Make sure the Level Indicator box at the right side of the toolbar is set to the appropriate floor 
level; you may use level A (All) to draw multiple levels simultaneously. Move the cursor to a 
spot on the Drawing Box and use the mouse to draw your shape: choose a starting point, then 
press and hold down the left mouse button as you move the mouse across the Draw Box. The 
perimeter footage appears as soon as you start to draw, and will change as you move the mouse. 
When you have reached the approximate dimensions of the section, release the mouse button. 
The dimensions will round off automatically; you can change the dimensions later if they are not 
correct.   
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Assigning a section label 
Once you finish drawing a shape, or section, the Label Section dialog box will appear. 
 
A few hints regarding section labels: 
 You may select more than one code for each section, to allow the standard “basement/main 

finished/upper finished” multi-story building layout.   
 You should select codes from the top down. (This is probably the reverse of what you’ve 

done in the past.) Start with the highest level, then work down to the basement. 
 As you select codes, the corresponding label appears in the “Label:” box. Multiple codes are 

separated by slashes. To modify the size of a code (for example, making upper finished area 
only .75 of the main finished area) type *.75 after the code in the label box. A standard Cape 
Cod-style house with a full basement would be labeled like this: 

 

  
 

If you are using the line or arc tools, the Label Section window described above will not appear 
until you have completed the section (in “old sketch” terms, when you “close the sketch”.) Select 
a usage code from the list (you may select more than one code) and modify the story height of a 
code if necessary by typing *.99 in the Label box immediately after the code (where *.99 equals 
the desired story height modifier, like *.50 or *.75.) Click the Clear Label button to start over or 
click the Done button to save the codes and close the window. The label and the base area will 
appear in the section. 
 

The Toolbar 
 
Various options are available both in menus and as icons. These icons are called tools, and they 
reside on a toolbar. Click the tool to select it. If you move the cursor over a tool and let it rest 
there for a few seconds, a “tool tip” will pop up to explain what the tool does. 
 
The drawing buttons are part of a larger Toolbar at the bottom of the Drawing Box.  To the right 
of the drawing icons are a set of buttons that perform various editing and display functions as 
described below. 
 
the Edit Section button   Click this icon, then click the sketch section you wish to 

edit or delete. The section lines will change to dotted lines. 
To edit, click and hold one of the handles (squares) and 
drag the perimeter to a new size.  To delete, click on the 
section to select it, then click the Delete Selected section 
button.  
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the Delete Selected Section button  Once you have selected a section using the Edit 

Section button above, you can delete the section by 
clicking this icon. 

 
the Edit Label button   Click this button, then click a label to edit. The Label 

Section window will pop up and allow you to make 
changes. When you are done editing the label, click the 
Done button. 

 
the Move Label button   Click this button, then click on a label and, while 

depressing the mouse button, drag the label to a new 
position. Now release the mouse button. 

 
the Zoom In/Zoom Out buttons   Use the Zoom In  button (magnifying glass with the 

plus + sign) to “zoom in” to, or enlarge, a particular 
area of the sketch. Use the Zoom Out button 
(magnifying glass with the minus - sign) to “zoom 
out” to see more of the sketch. 

                                      
the Pan Drawing button   Click this button and the cursor will change to a hand – 

grab the sketch by depressing the mouse button and move it 
to any location in the Draw Box. 

 
the One Foot Draw button   This button activates the One Foot Draw pad; it works only 

with the Polyline Tool. (The One Foot Draw pad is 
described below.) 

 
the Toggle Section Table button   This button will display or hide the Section Area 

Table. The perimeter and area of each completed 
sketch section is listed in the Section Area table. 

 
the Grid button   The Grid button toggles display of the background grid on/off. 

When toggled on, the grid will appear in the background as 
evenly spaced gray dots. (The grid does not print even when 
visible on screen.) 

 
the Undo Last Line button   Use this button with the Polyline Tool to remove the 

most recent line drawn. A line can only be removed if 
it is not part of a completed section – once the section 
is complete you must use the Select Section and 
Delete Selected Section buttons described above.  

 

the Autoscale Drawing button    The Autoscale button rescales your sketch to fit the 
window. 
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the Clear Drawing button   Clicking this button completely erases the Draw Box. 

Caution: If a sketch has been saved, it can be 
recovered by clicking File > Refresh on the menu bar; 
if the sketch has not yet been saved, it cannot be 
recovered.  

 
the Exit Sketch button   Quits the Sketch program. If the current sketch has 

not been saved the program will ask whether to save 
or discard it before quitting. 

 
 
the Level control buttons    The arrows and the Draw All Levels button control 

the display of the different levels (building stories) 
in a sketch: 

 
 The arrows allow you to view one level at a time. Click the 

Down arrow to move to lower levels like the Basement. 
Click the Up arrow to move higher in the sketch, through 
the first level to the 2nd, 3rd and higher levels.  If the 
“LevelColor-On” option is selected (it is turned on by 
default) the sketch color will change to indicate the 
different levels. The level indicator box changes as you 
click the arrows, showing you the current level. 

 

the Draw All Levels button     Clicking the Draw All Levels button returns the sketch to 
the normal display. All levels of the sketch are shown 
simultaneously, and an A appears in the level indicator box. 
You may use multiple labels in a section when drawing in 
“All levels” mode.     

The Status Line 
 
The white area below the Toolbar is known as the Status Line. Helpful information appears in 
this area as you select tools and options. If you can’t remember what a certain tool does, click the 
tool button and read the information on the Status Line for an explanation.  
 
 
 

 

The arc tool is 
selected…

The status line describes the arc tool 

dragging in drawing area. 
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Commercial Sketches 
 
Commercial sketches are drawn the same way that residential sketches are drawn – you use the 
same tools and options. There are two steps involved in sketching commercial properties: 
 
1. sketch the perimeter of each section 
2. assign a section label, including the story height. 
 
The label dialog box for a commercial sketch contains usage codes that refer only to the section 
number, not to the section’s use. Select the appropriate section number from the list, then select 
the proper story height for that section.  
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Select 
the 
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from the 
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For training and technical support… 

 
Contact any of the DOR CAMA Information Technology Staff for further assistance or to ask 
about training opportunities. 
 

CAMA Support Help Desk 
Monday – Friday 9A-4PM excluding holidays 

1-800-521-5536    (ask for CAMA Support or extension 62350) 
  

Advisor Phone E-mail 
Mike Quinlivan 508-792-7300 

extension 22313 
quinlivanm@dor.state.ma.us

Linda Bradley 617-626-2394  bradleyl@dor.state.ma.us  
Paul Corbett 617-626-2366 corbettp@dor.state.ma.us
Don Reynolds 617-626-2356 reynoldsd@dor.state.ma.us  
Arnold Kanter 617-626-2303 kanter@dor.state.ma.us  

 
All Boston staff can be reached by dialing their direct numbers or through the CAMA Support 
Help Desk. 
 
CAMA Version 3 User Guides, our Support Guidelines and other useful information from the 
Information Technology section of the Division of Local Services can be found online at 
http://www.dls.state.ma.us. Information about the Community Software Consortium can be 
found online at www.csc-ma.us. 

 

Division of Local Services Information Technology Section 
P.O. Box 9569 

Boston, MA 02114-9569 
(617) 626-2300 or toll free 1-800-521-5536 

Fax (617) 626-2330 
 

Kirsten Shirer, Deputy Director of Information Technology 
436 Dwight St. Room 401 

Springfield, MA 01103 
(413) 784-1000 Ext. 20613 

Fax (413) 784-1034 
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